Skip to main content Skip to footer

Upgrade your web browser to maintain access to Compass and WebEDI

To make sure you can continue to access Compass and WebEDI, we recommend you keep your web browser software up to date.

Compass and WebEDI are compatible with the following browser versions (v) or later:

  • Chrome v31
  • Edge v12
  • Firefox v27
  • Internet Explorer v11 (Windows 7)
  • Opera v20
  • Safari v9

If your browser is an earlier version you will need to upgrade it to maintain access to Compass and WebEDI.